In order to successfully apply SWAT, meteorological data local to the area being studied are required, at least for precipitation data. Normally, there are two ways to obtain local precipitation data: one is to go to the National Climatic Data Center (NCDC) website (www.ncdc.noaa.gov) to download precipitation data for your watershed, the other is to set up local rain gage stations. The former method is more practical for modeling a large watershed, while the latter can obtain more accurate rainfall data for a smaller watershed. It is also easier to attain sub-daily rainfall data through using local rain gage stations. Usually, the rainfall measurement device is set to record data once every five minutes. But most of precipitation data downloaded from the NCDC website are daily time series. If you are lucky, you may find some hourly precipitation data for a short time period for some weather stations. In this note, we will present a procedure for: (1) downloading daily precipitation data files from the NCDC website, (2) converting downloaded data into the format that is required by ArcView interfaces for SWAT (i.e., BASINS/SWAT or AVSWAT), and (3) writing the precipitation gage location table (dBase file).

A. Downloading daily precipitation data from NCDC

We will begin by downloading some precipitation data from the National Climatic Data Center (NCDC) for weather stations in the Upper Etowah River watershed, which was the subject of your Assignment 2.


2. Locate station using “Search by: Station Name/City” (You may use any other methods to locate weather stations in the interested area depending on what kind of information is available).

3. In the search box, type “Jasper, GA”.
4. Click the SEARCH button, the following Station List webpage shows there are three weather stations in the City of Jasper, GA.
5. In the column “Period of Record”, only the second station (Jasper 1 NNW) contains data up to the present. The other two weather stations were out of service at least 3 years ago. Therefore, click on “Jasper 1 NNW”, the following webpage will appear.
6. At the beginning of this page, you can find the information about this weather station\(^1\). For example, it shows the elevation, latitude and longitude of this weather station. It also shows the time period (years) when the weather station is (was) in service.

7. If the “In service” time period covers the years you wanted, click on “DATA” in the upper right corner, you’ll be brought to:

---

\(^1\) If there was only one weather station in this city, you would have bypassed step 5 and been brought to this webpage directly.
8. Click on “Digital ASCII Files”, you will see:

9. Click on “SOD-Daily Surface Data (TD3200/3210 combined)”.
10. Click on the “Continue With SIMPLIFIED Options” button, the following webpage appears.
11. In the “Data Range (Year/Month):” column, select the time period 1980/01 to 2004/12 (or the appropriate time period for your project).
12. Click on the “Continue” button. After a few seconds, the following webpage will appear.

13. Check the box in front of “Inventory Review” after you have viewed the inventory file by clicking on "View Inventory" in the above table. Type in your email address in the box after “E-mail Address:” and click on “Submit Request”. Then the following webpage pops up. It should be noted that if you’re using a university computer to download meteorological data from NCDC, you shouldn’t be asked for fees because the data are free of charge for users in non-profit organizations. If you are asked to purchase the data, either switch to another computer or let your network administrator know about it, who can easily solve your problem (but I don’t know how they do it).
14. If the database is functioning properly, it only takes a few minutes at most to process your request. Then you can access your files either by clicking on the hyperlink of the last line, or opening the email from NCDC in your email box. However, sometimes it takes a few days to process your request. Fortunately, this kind of situation does not happen very often, so it shouldn’t be an excuse for an overdue project!

15. Click on the hyperlink and you will get the following webpage.
16. There are four files that are relevant to your request. The first file is the data file in html format. You don’t need it. The second file is the data file in text format (ASCII file), which is what you need. The third file is the inventory file you just viewed before you submitted your request. The fourth file is the weather station characteristics. We will use the second and fourth files.

17. Click on the second file.
18. Click File → Save As to save the ASCII data file. Repeat to save the fourth file (station file).

B. Processing the downloaded data using MS Excel

Having downloaded the ASCII weather data from NCDC, the next step is to use MS Excel to process the downloaded precipitation data and save it into the format that the SWAT interface requires. The ASCII (.txt) table format for the precipitation data table required by the SWAT interface (either BASINS/SWAT or AVSWAT) is described on Page 12 of the AVSWAT 2000 User’s Manual (http://www.brc.tamus.edu/swat/downloads/doc/swatav2000.pdf).

1. Open MS Excel if it is not already open.

2. Click File → Open, and navigate to the directory that contains the downloaded precipitation data ASCII file. Change the file type (at the bottom of the Excel Open window) from "All Microsoft Excel Files" to "All Files".
3. Select the data file (151899640758.txt) and click Open. The Text Import Wizard window will pop up.

4. Select Delimited in the Original data type, and click Next >.
5. Select **Comma** in **Delimiters**, and click **Next >**.

6. Click **Finish**.

7. If you scroll down a little bit, you will find there is a blank row after the observations for the first month of 1980 (shown in the figure below). As a matter of fact, there is
always a blank row after the observations of each month. First, we need to get rid of these blank rows.

8. As shown below, Select the entire worksheet and click **Data → Filter → AutoFilter**.
9. Click on the downward arrow that is to the right of the column head of the first column “COOPID”; from the drop-down list, select “Nonblank.”
10. Then all blank rows will not be displayed. For example, as shown in the below figure, the row 33 is hidden.
11. Select the whole worksheet, and click **Edit → Copy**.

12. Open a new Excel worksheet by clicking on the "New" icon or clicking on **File → New**.

13. In the blank newly created Excel workbook, click **Edit → Paste**. The new Excel workbook now contains the meteorological data from Jasper 1NNW without blank rows.
14. Click **File → Save As** to save the current Excel workbook to a new name, say `jasper_precip.xls`. Then close the old data file for future use. From now on, we’ll work on the newly created Excel workbook.
15. If you scroll to the right, you will find the title for Column M is “Prcp”, which is a standard abbreviation for “precipitation”. The data contained in this column is the daily precipitation recorded by the “Jasper 1NNW” weather station. In this project, we don’t need other meteorological data except precipitation. Therefore, delete all other columns but the columns “year”, “month”, “day” and “prcp”.

![Excel spreadsheet image with data entries for precipitation and other meteorological parameters]
16. After this step, we will change the precipitation values from inches to mm (which is the unit SWAT uses). But before we do this, we have to contend with the cells that have missing values or text. If you scroll down, you will find in the “Prcp” column that some cells are empty (for example, in June of 1981 and December of 2003) and some cells contain “999.99”. These dates have missing values. Other cells have a "T" which stands for a "trace" of precipitation (which we will treat as a zero value). In SWAT, a missing value for precipitation should be -99.0 (see page 102 of the SWAT User’s Manual), but when we make the unit conversion that will change the value. For the moment, we will replace the missing values with “-1000”. Use **Edit → Replace** to change all "999.99" to "-1000" and to change all " " to "-1000". Use the same procedure to change all "T" to "0".

17. In this step, we need to convert the precipitation into “mm”. To the right of the “Prcp” column, create new column named as “Prcp (mm)”, and use a formula to multiply the value in inches by 25.4.
18. Copy the formula to the entire column, then copy the entire “Prcp (mm)” column. Use **Paste Special** to paste only the values (not the formula) of the column to the same positions. Then delete all other columns except the newly created column “Prcp (mm)”. But keep in mind that the starting date for this precipitation time series is “1/1/1980”.
19. Now use **Edit → Replace** to convert missing values of “-25,400” to “-99.0”. Then, select the entire column except the column head and click **Format → Cells**.
20. In the tab “Number”, select **Number** in **Category** and **1** in **Decimal places**. Then click on “OK”.

<p>| | | | | | | | | | |</p>
<table>
<thead>
<tr>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Prcp (mm)</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>2</td>
<td>8.9</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>3</td>
<td>0.0</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>4</td>
<td>0.0</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>5</td>
<td>8.9</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>6</td>
<td>1.3</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>7</td>
<td>0.0</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>8</td>
<td>0.0</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>9</td>
<td>8.4</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>10</td>
<td>1.8</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>11</td>
<td>0.0</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>12</td>
<td>0.0</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>13</td>
<td>20.3</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>14</td>
<td>0.0</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>15</td>
<td>7.6</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>16</td>
<td>0.0</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>17</td>
<td>nn</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

21. Now, replace the precipitation column head “Prcp (mm)” with a date string that represents the first date in the file, “19800101” as shown below.
22. Click **File → Save As**. In the pop-up window, select “Text (MS-DOS)” in the **Save As Type** box and type `pcpjasp` in the **File Name** box. **Save** the file and keep in mind where it was saved for writing the precipitation gage location table (below). Answer **Yes** when asked if you want to "keep the workbook in this format".
C. Writing precipitation gage location table

When the local measured precipitation data are to be used in SWAT, a precipitation gage location table is required to provide the locations of the rain gages. This table should be a dBase file. The format required by SWAT ArcView interfaces is described on page 19 of AVSWAT User’s Manual. Normally, ArcView is used to prepare this type of gage location table.

1. Open ESRI ArcView as a blank project, if it is not already open.

2. Click on “Table”.

![Save As dialog box](image)

File name: pcpjasp
Save as type: Text (MS-DOS)
3. Click “New”, and navigate to the directory where contains the processed precipitation file `pcpjasp.txt`. Then type “locpcp.dbf” in the File Name box.

4. Click “OK”.

---

2 For your project, both files should be placed in the user data directory.
5. Now, we are to add the Jasper 1 NNW precipitation gage into the precipitation gage location table. According to SWAT User’s Manual, each gage station occupies one row, in which there are 5 fields. They are ID, NAME, LAT (latitude), LONG (longitude), and ELEVATION. The latitude and longitude should be in degrees and the elevation should be in meters. All this information can be found in the station file that we downloaded along with the precipitation data file.

6. Click **Edit → Add Field**. Type ID in the Name box, select Number in the Type box, type 8 in the Width box, and type 0 in the Decimal Places box.

7. Click “OK”. The first field (ID Field) required is then added to the location table.
8. To add the NAME field, Click \textit{Edit} \rightarrow \textit{Add Field}. Type NAME in the Name box, select String in the Type box, and type 8 in the Width box.

![Field Definition]

9. Click \textit{Edit} \rightarrow \textit{Add Field}. Type LAT in the Name box, select Number in the Type box, type 8 in the Width box, and type 4 in the Decimal Places box.

![Field Definition]

10. Click \textit{Edit} \rightarrow \textit{Add Field}. Type LONG in the Name box, select Number in the Type box, type 8 in the Width box, and type 4 in the Decimal Places box.
11. Click **Edit → Add Field**. Type ELEVATION in the Name box, select Number in the Type box, type 8 in the Width box, and type 0 in Decimal Places box.

12. Click “OK”. The location table is ready for adding a rain gage station.

13. Click **Edit → Add Record**.
14. In the second group on the toolbar, click on the arrow with an “I” (the “Edit” icon).

15. Then click on each field of the added record and type in the relevant information.
   Please note that the name for this rain gage station should be the same as the name that you gave to the processed precipitation file. That is “pcpjasp”. In addition, the latitude and longitude are converted to decimal degrees from degree-minutes (divide the minutes by 60 to get the decimals). After you’ve finished inputting the gage information, click on the “Select” icon which is the large arrow. Otherwise, you will lose the data you just typed in.

16. Repeat steps from 13 to 15 for any other rain gage stations. It is worth repeating that the names for the rain gage stations in the NAME field should be the same as the precipitation data ASCII file’s base name.
17. Click Table → Stop Editing, and click Yes at the Stop Editing window. Notice that the field names become italic which indicates that the table is now non-editable.

18. Click File → Exit, and choose No at the pop-up window.

19. If it has not already been done, copy this precipitation gage location file and the precipitation data file(s) prepared in the previous section to the data directory of your SWAT model project.

Notes: This note only provides the directions for downloading daily precipitation data from NCDC website and preparing the corresponding precipitation data file(s) and precipitation gage location file. It is very similar to prepare data and location files for daily temperature and other meteorological data (but using comma to separate values). However, if you want to work on hourly or sub-hourly precipitation data, you are encouraged to read Chapter 7 (especially Section 7.2) very carefully. In such a case, a short computer program instead of Excel may be required.